Issues with storage provider

Incident Report for DashClicks

Resolved

The affected storage locations have been fully restored. The storage operator will continue to monitor over the weekend to ensure proper longterm operation. We believe we can safely mark this issue resolved at this time.
Posted May 31, 2024 - 20:21 EDT

Monitoring

Storage systems have been restored to operational status.
We'll continue to monitor these services.
If you experience any issue please reach out to our support team.
Posted May 31, 2024 - 00:02 EDT

Update

Recovery operation is currently underway to bring back the impacted systems. This will take between 6 to 12 hours to complete. We will continue to update here as progress is made.
Posted May 30, 2024 - 16:34 EDT

Update

We have identified more services impacted by this outage:

- Funnels: Some live domains and preview links are returning 404 Not Found.
- Forms: Creating new forms or loading existing forms hangs indefinitely.
Posted May 30, 2024 - 14:24 EDT

Identified

Our team has been made aware that one of our storage vendors is experiencing problems with their datacenters in multiple regions. These regions are experiencing a cooling issue, impacting the operating temperatures of hardware in those regions thus causing partial outage of our live funnels.

We will update with more information as we know more.
Posted May 30, 2024 - 13:43 EDT
This incident affected: Funnels and Forms.