Website Degraded Performance
Incident Report for DashClicks
Resolved
Our upstream provider has resolved issues on their end, and DashClicks Website is fully operational.
Posted Jun 13, 2023 - 18:22 EDT
Monitoring
Our upstream provider is continuing to investigate this incident. We’re closely monitoring this and working to improve performance for our customers and the DashClicks ecosystem.
Posted Jun 13, 2023 - 16:44 EDT
Identified
One of DashClicks' upstream providers is having issues with their services. This is resulting in outages for our website.
Posted Jun 13, 2023 - 15:26 EDT
This incident affected: Website.